File Upload Issues - US Region
Incident Report for Suralink
Resolved
The issue preventing file uploads for some users in the US region has been resolved.
Posted Nov 06, 2024 - 08:00 MST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 06, 2024 - 07:46 MST
Investigating
We are investigating an issue that is impacting file uploads in the US region. Our engineering teams are actively working to resolve the issue as quickly as possible. We will provide an update as soon as we have more information.
Posted Nov 06, 2024 - 07:33 MST
This incident affected: United States (File Uploads and Downloads).